Services down

Incident Report for AskHumans

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 07:16 UTC

Monitoring

Some of our AskHumans features don't work properly due to a major outage of AWS.
Posted Oct 20, 2025 - 18:38 UTC
This incident affected: Study, Loop, Report, Answers, Meeting, Presentation, and Webhook.